Welkom

De IPL-database is een verzameling van meetgegevens uit alle praktijkproeven die binnen het Innovatieprogramma Luchtkwaliteit zijn uitgevoerd

Bij het starten van de database verschijnt het beginscherm met een korte inleiding, de mogelijkheid om de taal van de databaseschermen te kiezen en een disclaimer.

Als de taal gekozen is wordt het hoofdscherm getoond. Het is een soort van schakelbord en vanuit dit scherm is alle functionaliteit van de database bereikbaar. De functionaliteit is in twee groepen verdeeld, die in aparte tabpagina’s is weergegeven:

  • De eerste groep biedt toegang tot een aantal schermen waarmee verschillende overzichten gecreëerd kunnen worden en is bedoeld voor de standaard gebruiker;
  • In de tweede groep bevinden zich een aantal handelingen die voor de beheerder nodig zijn voor het opslaan van meetgegevens in de database.

Rechts onder de tabpagina’s staat de knop om de database af te sluiten. Voor de afsluiting wordt de gebruiker gevraagd om deze actie te bevestigen.


Standaard gebruiker functionaliteit

De primaire functie van de database is het creëren van verschillende overzichten van de metingen die in de database opgeslagen zijn. De database ondersteunt het creëren van de volgende overzichten:

  • Luchtkwaliteit per uur
  • Luchtkwaliteit per 24 uur
  • Verkeer
  • Meteogegevens
  • Beschikbare meetgegevens

De gebruiker kan een overzicht kiezen door op de juiste knop op de eerste tabpagina te klikken.

Als de muisaanwijzer op een bepaalde knop staat krijgt de gebruiker meer informatie over de functionaliteit die achter de knop te vinden is. Naast de knop verschijnt dan de juiste beschrijving.


Lucht kwaliteit per uur

Om de metingen van de luchtkwaliteit per uur te bekijken dient de gebruiker de volgende stappen te volgen:

  • De selectie van de bron van de metingen uit de lijst met projecten. Dat kan op het niveau van een meetpunt binnen een project. De selectielijst met meetpunten van een project komt te voorschijn als de gebruiker op de bijbehorende knop [image] klikt.

De gebruiker maakt de selectie van een aantal meetpunten door middel van vinkjes binnen een apart scherm en bevestigt de selectie met de “Sluiten” knop. De geselecteerde meetpunten van het project staan dan in de lijst naast de projectnaam weergegeven.

Het is ook mogelijk om alle meetpunten van een project in een keer te selecteren of te wissen. Daarvoor kunnen de knoppen [image] en [image] gebruikt worden.

Meer informatie over een project, onder andere de meetopstelling, meetapparatuur, etc. wordt getoond als de gebruiker op de knop [image] klikt.

· De selectie van de meetwaarden die gerapporteerd moeten worden. Door middel van een vinkje kan een meetwaarde worden geselecteerd. Naast meetwaarden zoals PM10 en NOx kan de gebruiker ook twee groepen van extra waarden voor het overzicht selecteren. Dat zijn de meteogegevens en verkeersgegevens.

Tevens bestaat de mogelijkheid om meetwaarden voor twee meetpunten binnen een project te vergelijken. Zo kan het verschil tussen twee meetpunten worden weergegeven of kunnen twee meetpunten naast elkaar staan in een tabel en/of een grafiek.

· Het is vaak gewenst om een analyse te doen over de metingen in een bepaalde periode. Daarvoor kan een datumfilter ingeschakeld worden. Wanneer het vinkje aangezet wordt kan de gebruiker de onder- of bovengrens of beide grenzen voor de gewenste periode bepalen. Als alleen de ondergrens ingevoerd is worden alle metingen vanaf die datum (inclusief de datum) meegenomen. Als alleen de bovengrens is ingevoerd worden alle metingen tot en met die datum meegenomen. In het geval dat beide grenzen zijn ingevoerd worden de metingen die tussen de twee datums (inclusief beide datums) liggen meegenomen.

De datums kunnen ingetypt worden of vanuit een kalender geselecteerd worden. De kalender komt te voorschijn als de gebruiker op de knop [image] klikt. Op basis van de selectie van projectmeetpunten worden het begin en het einde van de totale meetperiode vermeld naast de datum invoervelden. Dat geeft de gebruiker een beter inzicht om een eigen datumfilter te kunnen definiëren. Deze twee datums worden ook als initiële selectie van de kalenders gebruikt.

Het filteren kan ook op basis van de tijd van de meting. Het gedrag is daar vergelijkbaar met het datumfilter. Het formaat van de tijdinvoer staat naast de invoervelden.

De tijdbasis van de metingen opgeslagen in de IPL database is Greenwich Mean Time – GMT.

· Vervolgens kunnen de metingen op basis van (meteo)randvoorwaarden gefilterd worden. Ook deze filters functioneren op dezelfde manier als de datum- en tijdfilters. Naast de filter invoervelden staan de eenheid van de waarde en de minimale en maximale waarde op basis van de selectie van project meetpunten.

· De actie uitvoeren met gebruik van de knoppen die zich helemaal onderaan bevinden.

De knop ‘Wis alle velden’ dient ervoor dat de velden weer terugkeren naar hun oorspronkelijke waarde.

Met de knoppen ‘Exporteer naar Excel tabel en grafiek’ en ‘Exporteer naar Excel tabel’ worden de gegevens op basis van gespecificeerde criteria uit de database gelezen en geëxporteerd als een tabel naar Excel. Dit is een volledige tabel met de naam van het project, de meetpuntnaam, de datum van de meting en de meetwaarden. In het eerste geval wordt er naast de tabel ook een grafiek gemaakt. Hierin worden de naam van het project en de meetpuntnaam meegenomen in de titel van de grafiek. De x-as wordt gevuld door de meetdatum en -tijd en de y-as wordt gebruikt voor de meetwaarden.

Met de tabel in Excel (het overzicht gemaakt door de database) is het mogelijk om zelf een grafiek te maken als deze niet bij de standaard grafieken zit.

Om terug te gaan naar het hoofdscherm dient de gebruiker op de knop “Sluiten” te klikken.


Lucht kwaliteit per 24 uur

Om de metingen van de luchtkwaliteit per 24 uur te bekijken dient de gebruiker de volgende stappen te volgen:

  • De selectie van de bron van de metingen uit de lijst met projecten. Dat kan op het niveau van een meetpunt binnen een project. De selectielijst met meetpunten van een project komt te voorschijn als de gebruiker op de bijbehorende knop [image] klikt.

De gebruiker maakt de selectie van een aantal meetpunten door middel van vinkjes binnen een apart scherm en bevestigt de selectie met de “Sluiten” knop. De geselecteerde meetpunten van het project staan dan in de lijst naast de projectnaam weergegeven.

Het is ook mogelijk om alle meetpunten van een project in een keer te selecteren of te wissen. Daarvoor kunnen de knoppen [image] en [image] gebruikt worden.

Meer informatie over een project, onder andere de meetopstelling, meetapparatuur, etc. wordt getoond als de gebruiker op de knop [image] klikt.

· De selectie van de meetwaarden die gerapporteerd moeten worden. Door middel van een vinkje kan een meetwaarde worden geselecteerd.

· Het is vaak gewenst om een analyse te doen over de metingen in een bepaalde periode. Daarvoor kan een datumfilter ingeschakeld worden. Wanneer het vinkje aangezet wordt kan de gebruiker de onder- of bovengrens of beide grenzen voor de gewenste periode bepalen. Als alleen de ondergrens ingevoerd is worden alle metingen vanaf die datum (inclusief de datum) meegenomen. Als alleen de bovengrens is ingevoerd worden alle metingen tot en met die datum meegenomen. In het geval dat beide grenzen zijn ingevoerd worden de metingen die tussen de twee datums (inclusief beide datums) liggen meegenomen.

De datums kunnen ingetypt worden of vanuit een kalender geselecteerd worden. De kalender komt te voorschijn als de gebruiker op de knop [image] klikt. Op basis van de selectie van projectmeetpunten worden het begin en het einde van de totale meetperiode vermeld naast de datum invoervelden. Dat geeft de gebruiker een beter inzicht om een eigen datumfilter te kunnen definiëren. Deze twee datums worden ook als initiële selectie van de kalenders gebruikt.

· De actie uitvoeren met gebruik van de knoppen die zich helemaal onderaan bevinden.

De knop ‘Wis alle velden’ dient ervoor dat de velden weer terugkeren naar hun oorspronkelijke waarde.

Met de knoppen ‘Exporteer naar Excel tabel en grafiek’ en ‘Exporteer naar Excel tabel’ worden de gegevens op basis van gespecificeerde criteria uit de database gelezen en geëxporteerd als een tabel naar Excel. Dit is een volledige tabel met de naam van het project, de meetpuntnaam, de datum van de meting en de meetwaarden. In het eerste geval wordt er naast de tabel ook een grafiek gemaakt. Hierin worden de naam van het project en de meetpuntnaam meegenomen in de titel van de grafiek. De x-as wordt gevuld door de meetdatum en de y-as wordt gebruikt voor de meetwaarden.

Met de tabel in Excel (het overzicht gemaakt door de database) is het mogelijk om zelf een grafiek te maken als deze niet bij de standaard grafieken zit.

Om terug te gaan naar het hoofdscherm dient de gebruiker op de knop “Sluiten” te klikken.


Verkeersgegevens

Om de verkeersgegevens te bekijken dient de gebruiker de volgende stappen te volgen:

  • De Selectie van de bron van de metingen uit de lijst met projecten. De selectie van de bron in geval van verkeersgegevens wordt op projectniveau gedaan. De gebruiker kan met een muisklik een of meerdere projecten uit de lijst selecteren.

  • De selectie van de tellingen die gerapporteerd moeten worden. Door middel van een vinkje kan een telling worden geselecteerd.

· Het is vaak gewenst om een analyse te doen over de metingen in een bepaalde periode. Daarvoor kan een datumfilter ingeschakeld worden. Wanneer het vinkje aangezet wordt kan de gebruiker de onder- of bovengrens of beide grenzen voor de gewenste periode bepalen. Als alleen de ondergrens ingevoerd is worden alle metingen vanaf die datum (inclusief de datum) meegenomen. Als alleen de bovengrens is ingevoerd worden alle metingen tot en met die datum meegenomen. In het geval dat beide grenzen zijn ingevoerd worden de metingen die tussen de twee datums (inclusief beide datums) liggen meegenomen.

De datums kunnen ingetypt worden of vanuit een kalender geselecteerd worden. De kalender komt te voorschijn als de gebruiker op de knop [image] klikt. Op basis van de selectie van projectmeetpunten worden het begin en het einde van de totale meetperiode vermeld naast de datum invoervelden. Dat geeft de gebruiker een beter inzicht om een eigen datumfilter te kunnen definiëren. Deze twee datums worden ook als initiële selectie van de kalenders gebruikt.

Het filteren kan ook op basis van de tijd van de meting. Het gedrag is daar vergelijkbaar met het datumfilter. Het formaat van de tijdinvoer staat naast de invoervelden.

De tijdbasis van de metingen opgeslagen in de IPL database is Greenwich Mean Time – GMT.

· De actie uitvoeren met gebruik van de knoppen die zich helemaal onderaan bevinden.

De knop ‘Wis alle velden’ dient ervoor dat de velden weer terugkeren naar hun oorspronkelijke waarde.

Met de knoppen ‘Exporteer naar Excel tabel en grafiek’ en ‘Exporteer naar Excel tabel’ worden de gegevens op basis van gespecificeerde criteria uit de database gelezen en geëxporteerd als een tabel naar Excel. Dit is een volledige tabel met de naam van het project, de meetpuntnaam, de datum van de meting en de meetwaarden. In het eerste geval wordt er naast de tabel ook een grafiek gemaakt. Hierin worden de naam van het project en de meetpuntnaam meegenomen in de titel van de grafiek. De x-as wordt gevuld door de meetdatum en -tijd en de y-as wordt gebruikt voor de meetwaarden.

Met de tabel in Excel (het overzicht gemaakt door de database) is het mogelijk om zelf een grafiek te maken als deze niet bij de standaard grafieken zit.

Om terug te gaan naar het hoofdscherm dient de gebruiker op de knop “Sluiten” te klikken.


Meteogegevens

Boven in het scherm “Meteogegevens” staat de titel en een korte uitleg wat de gebruiker met het scherm kan doen. Daaronder is een lijst waar de gebruiker de bron van de metingen kan selecteren. Afhankelijk van het project wordt de selectie van de bron op projectniveau of meetpuntniveau gedaan. De gebruiker kan met een muisklik een of meerdere items uit de lijst selecteren.

Voor het overzicht moet ook kenbaar gemaakt worden welke meetwaarden gerapporteerd moeten worden. Door middel van een vinkje kan een meetwaarde worden geselecteerd.

Om de meteogegevens te bekijken dient de gebruiker de volgende stappen te volgen:

  • De Selectie van de bron van de metingen uit de lijst. Afhankelijk van het project wordt de selectie van de bron op projectniveau of meetpuntniveau gedaan. De gebruiker kan met een muisklik een of meerdere items uit de lijst selecteren.

  • De selectie van de meetwaarden die gerapporteerd moeten worden. Door middel van een vinkje kan een meetwaarde worden geselecteerd.

· Het is vaak gewenst om een analyse te doen over de metingen in een bepaalde periode. Daarvoor kan een datumfilter ingeschakeld worden. Wanneer het vinkje aangezet wordt kan de gebruiker de onder- of bovengrens of beide grenzen voor de gewenste periode bepalen. Als alleen de ondergrens ingevoerd is worden alle metingen vanaf die datum (inclusief de datum) meegenomen. Als alleen de bovengrens is ingevoerd worden alle metingen tot en met die datum meegenomen. In het geval dat beide grenzen zijn ingevoerd worden de metingen die tussen de twee datums (inclusief beide datums) liggen meegenomen.

De datums kunnen ingetypt worden of vanuit een kalender geselecteerd worden. De kalender komt te voorschijn als de gebruiker op de knop [image] klikt. Op basis van de selectie van projectmeetpunten worden het begin en het einde van de totale meetperiode vermeld naast de datum invoervelden. Dat geeft de gebruiker een beter inzicht om een eigen datumfilter te kunnen definiëren. Deze twee datums worden ook als initiële selectie van de kalenders gebruikt.

Het filteren kan ook op basis van de tijd van de meting. Het gedrag is daar vergelijkbaar met het datumfilter. Het formaat van de tijdinvoer staat naast de invoervelden.

De tijdbasis van de metingen opgeslagen in de IPL database is Greenwich Mean Time – GMT.

· De actie uitvoeren met gebruik van de knoppen die zich helemaal onderaan bevinden.

De knop ‘Wis alle velden’ dient ervoor dat de velden weer terugkeren naar hun oorspronkelijke waarde.

Met de knoppen ‘Exporteer naar Excel tabel en grafiek’ en ‘Exporteer naar Excel tabel’ worden de gegevens op basis van gespecificeerde criteria uit de database gelezen en geëxporteerd als een tabel naar Excel. Dit is een volledige tabel met de naam van het project, de meetpuntnaam, de datum van de meting en de meetwaarden. In het eerste geval wordt er naast de tabel ook een grafiek gemaakt. Hierin worden de naam van het project en de meetpuntnaam meegenomen in de titel van de grafiek. De x-as wordt gevuld door de meetdatum en -tijd en de y-as wordt gebruikt voor de meetwaarden.

Met de tabel in Excel (het overzicht gemaakt door de database) is het mogelijk om zelf een grafiek te maken als deze niet bij de standaard grafieken zit.

Om terug te gaan naar het hoofdscherm dient de gebruiker op de knop “Sluiten” te klikken.


Beschikbare gegevens

Voor alle overzichten is het noodzakelijk om een of meer projecten en/of meetpunten te selecteren. Soms weet de gebruiker niet welke gegevens per project beschikbaar zijn.

In het overzicht staan alle metingen die ooit geïmporteerd zijn in de database. De gebruiker kan vanuit het overzicht per project zien welke soort van metingen aanwezig zijn en in welke periode de metingen zijn uitgevoerd.


Beheer functionaliteit

De database is een verzameling van meetgegevens die aangeleverd zijn door externe partijen. Daarom moet de database ook functionaliteit hebben om meetgegevens te kunnen importeren, verwerken en verwijderen.

Om meetgegevens in de database te kunnen importeren moeten ze in het formaat van een Excel sheet beschikbaar zijn. Als de gegevens in een ander formaat door de leverancier wordt opgeleverd dan dienen ze voor het importeren naar de database eerst naar Excel formaat omgezet te worden.

Het type bestand wordt op basis van de extensie bepaald. Dus alle bestanden die eindigen op xls worden als Excel bestanden gezien.


Gegevens importeren

Voor het importeren van de gegevens vanuit een Excel bestand moet de volgende keuzes gemaakt worden:

  • Er een keuze gemaakt worden over welk project het gaat door een projectnaam uit de selectielijst te selecteren.
  • Daarna moet ook de leverancier bekend zijn waar de meetgegevens vandaan komen.
  • En als laatste is het van belang welke meetgegevens er worden ingelezen, wat door middel van een keuzerondje aangegeven kan worden.
  • Selectie van het bestand kan met behulp van de [image] knop gedaan worden.

Als alle parameters bekend zijn wordt met een klik op de “Importeren” knop het bestand ingelezen.

Resultaat van deze actie is een tijdelijke tussentabel in de database. De naam van de tussentabel wordt uit de projectafkorting, het type van de meetgegevens en de datum en tijd van het importeren samengesteld.

Tijdens het importeren wordt er ook een logbestand bijgehouden waarin staat welk bestand, project en meting er wordt ingelezen. Ook als er een fout voorkomt wordt het in het log bestand geregistreerd. De log bestanden bevinden zich in een onder-liggende map (Projects\Log).

In MS Access is het, in tegenstelling tot MS Excel, niet mogelijk om een veldnaam te hebben die een punt bevat. Zo kan een Excel bestand een kolomnaam PM2.5 hebben. Tijdens het importeren wordt dit door Access automatisch naar een veldnaam PM2#5 in de tussentabel omgezet.


Gegevens verwerken

De gegevens vanuit de tussentabellen moeten verder verwerkt worden in de onderliggende tabellen. Tijdens het verwerken zal de gebruiker voor een geselecteerde importsessie (tussentabel) de betekenis van de kolommen bepalen en de juiste verwijzingen naar de kolommen van de onderliggende tabellen definiëren. Dat kan gedaan worden als de gebruiker op het “Verwerken gegevens” scherm de volgende stappen volgt:

  • Op het scherm moet de gebruiker eerst een importsessie selecteren. Daarvoor moet eerst het juiste type meting uit de lijst geselecteerd worden.
  • Op basis van de selectie wordt de volgende selectielijst samengesteld met alle importsessies van meetgegevens van dit type die nog niet verwerkt zijn. Een importsessie wordt in de lijst gepresenteerd met de projectnaam, leverancier en datum en tijd van de sessie.
  • Na de selectie van een sessie komt de naam van de betreffende tussentabel in het invoerveld tevoorschijn.
  • In het vakje “Kolomverwijzingen” dient de gebruiker de betekenis van de kolommen van de tussentabel te bepalen. Om meetgegevens te kunnen verwerken is het noodzakelijk om de meetdatum en -tijd aan meetwaarden te koppelen. Daarom is het verplicht ofwel de 'Datum en tijd' kolom of een combinatie van 'Datum' en 'Tijd' kolommen te selecteren uit de kolommen van de tussentabel. Alle selectielijsten bieden hier alle kolommen van de tussentabel als een mogelijke verwijzing. Als ergens geen selectie wordt gemaakt impliceert dat dat de meetwaarde niet in het importbestand opgenomen wordt.
  • Tevens kan de gebruiker ook verwijzingen voor de meteogegevens definiëren. Afhankelijk van het project kunnen deze verwijzingen gezamenlijk voor alle meetpunten van het project zijn of worden ze later per meetpunt gedefinieerd.
  • Aan het eind staat een tabel waarin elke rij de verwijzingen voor een project meetpunt vastlegt (de meetpunten van het project zijn vooraf gedefinieerd).
  • Als alle verwijzingen ingevuld zijn worden met een klik op de “Verwerken” knop de gegevens vanuit de tijdelijke tussentabel verwerkt en de importsessie afgesloten. De tussentabel wordt daarna verwijderd.

Alle verwijzingen worden in de database apart opgeslagen. De gebruiker hoeft een geselecteerde importsessie niet direct te verwerken. Met de “Sluiten” knop worden de verwijzingen opgeslagen en het scherm afgesloten. Op een later moment kan de gebruiker dezelfde importsessie weer selecteren, nog een aantal verwijzingen definiëren en eventueel verwerken.


Gegevens verwijderen

Op het scherm staat een lijst met alle importsessies waarin per sessie de projectnaam, het type metingen, de meetperiode en de verwerkingsdatum staan. Om een importsessie te verwijderen dient de gebruiker de volgende stappen te volgen:

  • Met een muisklik kan de te verwijderen sessie geselecteerd worden.
  • Na de selectie en een klik op de knop “Verwijderen” wordt de gebruiker gevraagd om deze actie te bevestigen. Op basis van de keuze worden alle gegevens van de importsessie uit de database verwijderd of wordt de actie geannuleerd. In het eerste geval staat de gekozen sessie niet meer in de lijst.